首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
推荐学习书目
Learn Python the Hard Way
Python 学习手册
Python Cookbook
Python 基础教程
Python Sites
PyPI - Python Package Index
http://www.simple-is-better.com/
http://diveintopython.org/toc/index.html
Pocoo
值得关注的项目
PyPy
Celery
Jinja2
Read the Docs
gevent
pyenv
virtualenv
Stackless Python
Beautiful Soup
结巴中文分词
Green Unicorn
Sentry
Shovel
Pyflakes
pytest
Python 编程
pep8 Checker
Styles
PEP 8
Google Python Style Guide
Code Style from The Hitchhiker's Guide
V2EX  ›  Python

采访一下各位,目前主要用的是 Python 2 还是 3?

  •  
  •   lincanbin · 2014-11-13 11:48:34 +08:00 · 4730 次点击
    这是一个创建于 1561 天前的主题,其中的信息可能已经有所发展或是发生改变。
    想看看Python搞分裂后发展得怎么样?
    我现在还是用Python 2,电脑里也装了个Python 3可是不好用。
    30 回复  |  直到 2014-11-16 18:07:43 +08:00
        1
    ixiaohei   2014-11-13 12:02:09 +08:00
    我没有用过python,貌似一般都是用的2.x,3很少有项目用
        2
    zhouquanbest   2014-11-13 12:05:53 +08:00
    生产环境2
    自己折腾3
        3
    bingwenshi   2014-11-13 12:06:03 +08:00
    Python 3 不好用体现在哪里呢 ?
        4
    invsbelephant   2014-11-13 12:08:30 +08:00
    自己玩还是2
        5
    aszxqw   2014-11-13 12:25:10 +08:00
    @bingwenshi
    不是不好用,是不兼容。
        6
    tini8   2014-11-13 12:33:25 +08:00
    php和java份额高的原因,很重要的一个就是向前兼容做的好。哪怕语言创立之初有很多不完美的地方,为了向前兼容也不轻易改动它,这样企业才敢用,企业用的多程序员才好找工作。
        7
    2owe   2014-11-13 12:57:17 +08:00
    2k和3k写出来的都是 python style,feel 没变。

    感觉上写兼容3k的代码时,代码风格也会更整洁些呢…
        8
    toooddchen   2014-11-13 12:59:52 +08:00
    用2.7
        9
    zonyitoo   2014-11-13 13:07:53 +08:00
    自己玩用3或使用2.7+使用__future__兼容3
        10
    kidlj   2014-11-13 13:14:55 +08:00
    系统全局是2.7,自己的项目用virtualenv跑 Python 3.
        11
    Kabie   2014-11-13 13:21:16 +08:00
    基本不用2...当然现在连Python都很少写了...
        12
    owen1989   2014-11-13 15:37:12 +08:00
    基本还是2.x居多吧
        13
    ming2281   2014-11-13 15:48:14 +08:00
    先用2.x,然后再学习3.x, 2和3你都会要学,再说也没有什么难度
        14
    zhangkai_ch   2014-11-13 17:16:26 +08:00
    2.7
        15
    timbotetsu   2014-11-13 17:19:40 +08:00
    2.7.6
    3打算直接放弃等4
        16
    pc10201   2014-11-13 17:52:21 +08:00
    scrapy还是只能跑在2上面,生产环境还是用2吧~因为还有许多库只有2的版本
        17
    xuwenhao   2014-11-13 19:26:56 +08:00
    python 2
    虽然我其实不太会用python
        18
    clino   2014-11-13 21:21:22 +08:00
    2.7
        19
    BiggerLonger   2014-11-13 22:56:56 +08:00
    这算是月经帖吗, 2.7.8, 有种用2.6....
        20
    onemoo   2014-11-13 23:04:02 +08:00
    @ming2281
    我还没学过python,但是目前已知的一个需求是用3的,所以想先从3入手。那么以后再学2的话也没什么问题吧?
        21
    DiffView   2014-11-14 01:16:05 +08:00
    小明:Python是什么?
    小方:就是那个放在Windows下跑就各种编码错误的语音啊
        22
    oloopy   2014-11-14 01:30:17 +08:00 via iPhone
    Wireluker检测工具用2写的。一个小东西如果自己只有3就特折腾。
        23
    wenbinwu   2014-11-14 07:04:53 +08:00
    fabric还不支持py3
        24
    lincanbin   2014-11-14 08:55:42 +08:00 via Android
    @robinxiaobin 还好啊,我的开发环境就是Windows,生产环境CentOS,本地能跑扔上去也能跑
        25
    RW667   2014-11-14 13:40:25 +08:00
    python2x 的编码错误真的是很蛋疼...
    期待3普及
        26
    ming2281   2014-11-14 14:02:19 +08:00   ♥ 1
    @onemoo 没有问题啊,本来2和3之间的差别还没有达到天壤之别,只不过创始人决定让3不兼容2而已,Python强大的地方不在语言本身,在于丰富的第三方库, 主流第三方库使用的哪个版本,你就使用哪个版本. -->3是肯定要学习的,因为是未来嘛.
    你学了就知道了,问这些问题的都是还没有开始学习的,
        27
    onemoo   2014-11-14 22:20:07 +08:00
    @ming2281
    恩。我使用的一个软件是用python3做插件系统的,所以目前的需求就是用3版。日后再转2没那么多坑就好。
    谢谢。
        28
    ming2281   2014-11-15 20:33:52 +08:00   ♥ 1
    @onemoo 不得不说,Python的这种不兼容性是非常不好的,首先就是对程序员不友好,显而易见的一点是:Python2.x和Python3.x会发展成为两门不同的语言,至少在相当长的时间里会是这样
        29
    wolfan   2014-11-16 17:32:03 +08:00
    2.x的教程更多吧,所以2.x的人多。
        30
    Bismarrck   2014-11-16 18:07:43 +08:00
    目前在用也只能用2.7,服务器环境决定的。虽然很想试试python3.
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2556 人在线   最高记录 4385   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 19ms · UTC 13:25 · PVG 21:25 · LAX 05:25 · JFK 08:25
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1