首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  macOS

macOS 是不是把 beta 版的 command line tool 推送给了所有人?

  •  
  •   PureWhite · 261 天前 · 3155 次点击
    这是一个创建于 261 天前的主题,其中的信息可能已经有所发展或是发生改变。

    如题。

    装完之后 ruby 不能用了。

    24 回复  |  直到 2018-06-06 08:43:28 +08:00
        1
    hanangellove   261 天前
    真的吗, 那看来还是不要装啊
        2
    hanangellove   261 天前
    发个错误截图看看
        3
    ryh   261 天前
    如果是 for Xcode 9.4 的话不是,Xcode9.4 是 5 月 31 日推送的普通版本
    新 beta 是 Xcode10
        4
    pmgh10   261 天前
    是的推错了,WWDC 开昏了
        5
    chyiz   261 天前
    在更新里看到了,Command Line Tools (macOS High Sierra version 1013) beta 1 for Xcode 10.0 ...
    赶紧把自动更新关了……
    🍎💊
        6
    Cavolo   261 天前 via iPhone
    一样,更的时候还纳闷我没装 Xcode10 啊
        7
    Cavolo   261 天前 via iPhone
    感觉苹果还得推一波让我们降下来
        8
    anyforever   261 天前
    呃、已经装完了。。自启动的时候,界面假死,强按关机键启的,不知道跟更了哪个有关
        9
    oneyian   261 天前
    iMac (Retina 4K, 21.5-inch, 2017) - v10.13.5 — Xcode 9.4 刚成功更新这次的 beta 版,目前没遇到什么错误
        10
    Kamiimeteor   261 天前
    @oneyian 能帮我 test 一下 sketch 这个应用有 bug 吗?
        11
    PDX   261 天前
    bate 版居然推送了。。。
        12
    seaswalker   261 天前 via iPhone
    对,我的也是,特么 idea 滚动变得非常卡,不知道和这个东西有没有关系
        13
    zj299792458   261 天前
    同推送,理论上这个装了之后如果有 xcode 依然还是用 xcode 里面的,除非你没装 xcode,删除只要执行:
    rm -rf /Library/Developer/CommandLineTools 就行了,然后 xcode-select 重新安装正式版。
        14
    zj299792458   261 天前
    @zj299792458 有 xcode 的话只要确保 xcode-select -p 的路径是 xcode 而不是 /Library/Developer/CommandLineTools 理论上就没影响吧
        15
    anyforever   261 天前
    我装了 10 的 beta 版,重启了 app store 之后,更新历史里居然显示的是 9.4 的了。。上面还有一个在等待更新的 9.4,半天了也更不了。。icon 标上一直显示那个 1 了。。。
        16
    tulongtou   261 天前
    是的,一早我也更新了这个,不过 brew 安的 ruby 没受影响,rails 还是跑的舒舒服服
        17
    oneyian   261 天前
    @Kamiimeteor v48.1 可以正常启动
        18
    geying   261 天前
    ![]( https://i.loli.net/2018/06/05/5b16356db1acd.png)

    为什么我更新了三遍 我其实是想升级新系统 下了 6 个多 G 的东西更新完发现并没有推送
        19
    HayesTsai   261 天前
    大家都是做 iOS 开发的嘛? 我从来没用过 Xcode...
        20
    kingcos   261 天前 via iPhone
    @HayesTsai Command Line Tools 并不都是 iOS 开发者才需要的
        21
    zha0300   261 天前
    我是安装了最新的 command line tool beta 1, brew 更新 gnuplot 的时候报错 是 clang 版本不对 rm 了 beta1 换为 9.4 就没这问题了
        22
    huwei223   261 天前
    装的太快了 我刚发现 for xcode10 就结束了。。。
        23
    Kamiimeteor   261 天前
    @oneyian 求测 50.2~~
        24
    maemolee   260 天前
    这个推送已经撤回了。昨天我看见更新,马上关闭了自动更新,刚才看了看这条已经没了。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2510 人在线   最高记录 4385   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 288ms · UTC 14:19 · PVG 22:19 · LAX 06:19 · JFK 09:19
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1